Jan 15, 2015 at 4:09 PM
I am getting this error trying to send a file to one of our vendors. The component is working for other vendors and I was able to successfully send a file yesterday. Today, it is only erroring out. When I run it manually, I get the following:
Information: START SFTP Task
Information: The rendered local path is: C:\Mailbox\File Transfers...\20150115_MyStudentData.csv
Information: SFTP Server: "sftp.....com", User "..."
Information: SFTP port: 22
Information: The SFTP operation will be encrypted by a private key file
Information: The path to the private key file is: C:\Mailbox\File Transfers...\filename
Information: The Pass Phrase is:
Information: Preparing to copy the file(s) C:\Mailbox\File Transfers...\20150115_MyStudentData.csv to /student-data
Error: Error : Exception of type 'Tamir.SharpSsh.jsch.SftpException' was thrown.

I have double checked and the local path and file name are correct and are CaSe sensitive. The remote path is also correct and CaSe sensitive. Interestingly enough, the vendor is indicating receipt of a 0 byte file. This tells me we have connected and created the file, it just isn't sending. Any ideas since the error doesn't give me anything to go on? Here is the component in design:

Jan 15, 2015 at 8:36 PM
I heard back from our vendor just a few minutes ago. They discovered the disk was full on their server, arg! Wish they would have found this first before trying to say the problem was on our end. All is working perfectly now. Thank you for a great component!
Marked as answer by jimtpowers on 1/15/2015 at 12:36 PM
Jan 23, 2015 at 5:52 PM
Hi Jim,

I'm currently working on automating this task and have already downloaded the SSIS SFTP Task Control Flow Component, so hope you could help me with my issue.

I got the putty private key and could connect to the host fine via WinSCP. Now as I understand I have to convert the key to open SSH in order to use the SSIS SFTP Task Control Flow Component, right? I used PuttyGen to do the conversion but not sure what is missing that I got the [SSISSFTTask] Error: Error : Authentication failed.

As you have already got this working, would you please help me to fix the issue? What else should I do in order to connect to the host with this SSIS SFTP Task Control Flow Component?

Thank you so much for your help!
Feb 11, 2016 at 2:47 AM
I got same error here. There´s a solution already ?